【Go 基础 】mod 包管理

go mod包管理

基本每个语言都有自己的包管理工具,node的npm,yarn;Python pipenv,venv;Java的maven等等,go 当然也有自己的包管理工具 mod(Modules简写)

参考链接

要求go版本>=1.11,推荐go 1.13或以上版本。

首先环境配置

linux or Mac环境变量 参考 https://goproxy.io/zh/

go env -w GO111MODULE=auto
go env -w GOPROXY=https://goproxy.io,direct

初始化

cd 项目文件夹            // 进入项目文件夹下
go mod init gin-stydy  // gin-stydy为项目名(随意取)
// 就会创建go.mod文件

常见命令

go list // 列出主模块(当前模块)
go list -m all // 列出了当前模块及其所有依赖项

安装依赖指定版本

go get github.com/gin-gonic/gin@version

升级库依赖, 比如Gin框架 升级

go get -u github.com/gin-gonic/gin

安装依赖指指定分支

go get github.com/gin-gonic/gin@master

github 拉取 他人含有go.mod的项目时,下载所有第三方包

go mod download

删除未使用的依赖项

go mod tidy

验证依赖是否正确

go mod verify

goland 配置

Setting>Go Modules配置; 在这里插入图片描述

总结

使用工具,用到的时候查手册就行了,做好笔记很重要。


文章作者: 王小右
版权声明: 咳咳想白嫖文章?本文章著作权归作者所有,任何形式的转载都请注明出处。 https://www.charmcode.cn !
  目录